<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<meta name="robots" content="index, follow, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<title>Black Stars has a lot of quality players – Emmanuel Agyemang-Badu</title>
<meta name="description" lang="en" content="Former Black Stars midfielder, Emmanuel Agyemang-Badu, has rejected claims that Ghana lacks quality players."/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:site" content="@TheGhanaWeb"/>
<meta name="twitter:title" content="Black Stars has a lot of quality players – Emmanuel Agyemang-Badu"/>
<meta name="twitter:url" content="https://www.ghanaweb.com/GhanaHomePage/SportsArchive/Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603" />
<meta name="twitter:description" content="Former Black Stars midfielder, Emmanuel Agyemang-Badu, has rejected claims that Ghana lacks quality players."/>
<meta name="twitter:image" content="https://cdn.ghanaweb.com/imagelib/pics/819/81948914.jpg"/>
<meta property="og:site_name" content="GhanaWeb"/>
<meta property="og:type" content="article"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:title" content="Black Stars has a lot of quality players – Emmanuel Agyemang-Badu"/>
<meta property="og:image" content="https://cdn.ghanaweb.com/imagelib/pics/819/81948914.jpg"/>
<meta property="og:image:width" content="600"/>
<meta property="og:image:height" content="486"/>
<meta property="og:url" content="https://www.ghanaweb.com/GhanaHomePage/SportsArchive/Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603"/>
<meta property="og:description" content="Former Black Stars midfielder, Emmanuel Agyemang-Badu, has rejected claims that Ghana lacks quality players."/>
<meta property="article:published_time" content="2021-10-08T17:15:43+00:00"/>
<meta property="article:modified_time" content="2021-10-08T17:15:43+00:00"/>
<link rel="canonical" href="https://www.ghanaweb.com/GhanaHomePage/SportsArchive/Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603"/>
<link rel="shortcut icon" href="https://cdn.ghanaweb.com/design/favicon.ico?asdas=32156646" type="image/x-icon">
<link href="https://cdn.ghanaweb.com/css/GH/v4.8.7/common.css" rel="stylesheet" type="text/css" media="screen">
<link href="https://cdn.ghanaweb.com/css/GH/v4.8.7/common.other.css" rel="stylesheet" type="text/css" media="screen">
<link href="https://cdn.ghanaweb.com/css/GH/v4.8.7/sports.css" rel="stylesheet" type="text/css" media="screen">
<link href="https://cdn.ghanaweb.com/css/GH/v4.8.7/print.css" rel="stylesheet" type="text/css" media="print">
<link rel="apple-touch-icon" href="https://cdn.ghanaweb.com/design/apple-touch-icon-ipad.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://cdn.ghanaweb.com/design/apple-touch-icon-iphone4.png">
<script language="Javascript" type="text/javascript" src="https://cdn.ghanaweb.com/jscript/v2.23/jquery.min.js"></script>
<link rel="alternate" media="only screen and (max-width: 640px)" href="https://mobile.ghanaweb.com/GhanaHomePage/SportsArchive/Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603"/>
<link rel="preconnect" href="https://log.outbrainimg.com">
<link href="https://widgets.outbrain.com/" rel="preconnect">
<link href="https://cdn.ghanaweb.com/" rel="preconnect">
<link href="https://ajax.cloudflare.com/" rel="preconnect">
<link href="https://ajax.cloudflare.com/" rel="dns-prefetch">
<link href="https://adservice.google.com" rel="preconnect">
<link href="https://adservice.google.com" rel="dns-prefetch">
<link href="https://www.googletagmanager.com" rel="preconnect">
<link href="https://certify-js.alexametrics.com/" rel="preconnect">
<link href="https://certify.alexametrics.com/" rel="preconnect">
<link href="https://pagead2.googlesyndication.com/" rel="dns-prefetch">
<script data-cfasync="false" async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
	var googletag = googletag || {};
	googletag.cmd = googletag.cmd || [];
</script>
<script>
			var gptadslots = [];
		  	googletag.cmd.push(function() {
	gptadslots[1] = googletag.defineSlot('/3810627/GH/WLB1', [[468, 60], [970, 90], [728, 90]], 'div-gpt-ad-1100003-0').addService(googletag.pubads()).setTargeting('targeting', ['Sport']);
	gptadslots[2] = googletag.defineSlot('/3810627/GH/MR1', [[300, 250], 'fluid'], 'div-gpt-ad-1300003-0').addService(googletag.pubads()).setTargeting('targeting', ['Sport']);
	gptadslots[3] = googletag.defineSlot('/3810627/GH/MR2', [[300, 250], 'fluid'], 'div-gpt-ad-1300003-1').addService(googletag.pubads()).setTargeting('targeting', ['Sport']);
	gptadslots[4] = googletag.defineSlot('/3810627/GH/WSS1', [[300, 600], [160, 600], 'fluid'], 'div-gpt-ad-1200003-0').addService(googletag.pubads()).setTargeting('targeting', ['Sport']);
	gptadslots[5] = googletag.defineSlot('/3810627/GH/WSS2', [[300, 250], 'fluid'], 'div-gpt-ad-1200003-1').addService(googletag.pubads()).setTargeting('targeting', ['Sport']);
	googletag.pubads().enableSingleRequest();
		    googletag.pubads().disableInitialLoad();
		    googletag.pubads().setRequestNonPersonalizedAds(0);
		    googletag.enableServices();
		  });
		</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-40951090-2"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('config', 'UA-40951090-2');
</script>
<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"Rv2Th1aon800ah", domain:"ghanaweb.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=Rv2Th1aon800ah" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->

<script type="application/ld+json">
		{
			"@context": "https://schema.org",
			"@graph": [
				{
				"@type": "NewsArticle",
					"articleSection": "Sports",
					"name": "Black Stars has a lot of quality players – Emmanuel Agyemang-Badu",
					"headline": "Black Stars has a lot of quality players – Emmanuel Agyemang-Badu",
					"description": "Former Black Stars midfielder, Emmanuel Agyemang-Badu, has rejected claims that Ghana lacks quality players.",
					"datePublished": "2021-10-08T17:15:43+00:00",
					"dateModified": "2021-10-08T17:15:43+00:00",
					"inLanguage": "en",
					"thumbnailUrl": "https://cdn.ghanaweb.com/imagelib/src/Emmanuel-Agyemang-Badu1.jpg",
					"mainEntityOfPage": {
						"@type": "WebPage",
						"@id": "https://www.ghanaweb.com/GhanaHomePage/SportsArchive/Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603"
					},
					"url": "https://www.ghanaweb.com/GhanaHomePage/SportsArchive/Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603",
					"image": {
						"type": "ImageObject",
						"url": "https://cdn.ghanaweb.com/imagelib/src/Emmanuel-Agyemang-Badu1.jpg",
						"caption": "Former Black Stars midfielder, Emmanuel Agyemang-Badu",
						"width": "600",
						"height": "486"
					},
					"publisher": {
						"@type": "NewsMediaOrganization",
						"@id": "https://www.ghanaweb.com/#publisher",
						"name": "GhanaWeb",
						"url": "https://www.ghanaweb.com",
						"diversityPolicy": "https://www.ghanaweb.com/GhanaHomePage/standards-and-policies.php",
						"ethicsPolicy": "https://www.ghanaweb.com/GhanaHomePage/standards-and-policies.php",
						"actionableFeedbackPolicy": "https://www.ghanaweb.com/GhanaHomePage/standards-and-policies.php",
						"correctionsPolicy": "https://www.ghanaweb.com/GhanaHomePage/standards-and-policies.php",
						"unnamedSourcesPolicy": "https://www.ghanaweb.com/GhanaHomePage/standards-and-policies.php",
						"verificationFactCheckingPolicy": "https://www.ghanaweb.com/GhanaHomePage/standards-and-policies.php",
						"publishingPrinciples": "https://www.ghanaweb.com/GhanaHomePage/standards-and-policies.php",
						"foundingDate": "1999-01-01",
						"sameAs": ["https:\/\/www.wikidata.org\/wiki\/Q83495671","https:\/\/en.wikipedia.org\/wiki\/GhanaWeb","https:\/\/play.google.com\/store\/apps\/details?id=com.ghanaweb.radio","https:\/\/www.facebook.com\/TheGhanaWeb\/","https:\/\/twitter.com\/TheGhanaWeb","https:\/\/www.instagram.com\/theghanaweb\/","https:\/\/www.linkedin.com\/company\/theghanaweb\/","https:\/\/www.youtube.com\/channel\/UCsL03z5sLvA0t8sjwDWf_3A"],
						"address": {
								"@type": "PostalAddress",
								"streetAddress": "Daalwijkdreef 47",
								"addressLocality": "Amsterdam",
								"postalCode": "1103 AD",
								"addressCountry": "NL"
							},
						"contactPoint": {
								"@type": "ContactPoint",
								"email": "info@ghanaweb.com",
								"telephone": "+31 20 362 9956",
								"areaServed": "Worldwide",
								"availableLanguage": ["English"]                    },
						
						"logo": {
							"@type": "ImageObject",
							"url": "https://cdn.ghanaweb.com/design/logo_desktop.png",
							"width": "243",
							"height": "30"
						}
					}
				},
				{
					"@type": "BreadcrumbList",
								"itemListElement": [
						{
							"@type": "ListItem",
							"position": 1,
							"name": "Home",
							"item": "https://www.ghanaweb.com"
						},
						{
							"@type": "ListItem",
							"position": 2,
							"name": "Sports",
							"item": "https://www.ghanaweb.com/GhanaHomePage/SportsArchive/"
						},                
						{
							"@type": "ListItem",
							"position": 3,
							"name": "Black Stars has a lot of quality players – Emmanuel Agyemang-Badu",
							"item": "https://www.ghanaweb.com/GhanaHomePage/SportsArchive/Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603"
						}
					]
				}
			]
		}
		</script></head>

<body><div id="pagecontainer" class="sports">
<header id="news" class="sports">
        <div id="headerTop">
           <div id="navLogo"><a href="https://www.ghanaweb.com/"> <img src="https://cdn.ghanaweb.com/design/logo_desktop.png"  title="Desktop Logo" alt="Desktop Logo"></a></div>
			
                       <div id="navLinks">
             <div id="socialbtn">
               <a href="https://www.youtube.com/channel/UCsL03z5sLvA0t8sjwDWf_3A" rel="noopener" class="yt" target="_blank">Youtube Icon</a>               <a href="https://www.facebook.com/TheGhanaWeb" rel="noopener" class="fb" target="_blank">Facebook Icon</a>               <a href="https://twitter.com/theghanaweb" rel="noopener" class="tw" target="_blank">Twitter Icon</a>             </div>

             <div class="flexsearch--wrapper">
                <form class="flexsearch--form" action="https://www.ghanaweb.com/GhanaHomePage/search.php" method="post">
                <input type="hidden" name="action" value="1" />
                <input type="hidden" name="search_mode" value="news" />
                  <div class="flexsearch--input-wrapper">
                    <input class="flexsearch--input" type="search" name="Search" placeholder="Search GhanaWeb" value="">
                  </div>

                  <div class="flexsearch--submit-wrap">
                      <input class="flexsearch--submit" type="submit" value="">
                  </div>
				
                  <div id="loginLinks">
                                        <a href="https://www.ghanaweb.com/wall/private/register.php" class="signUp">Sign up</a>
                      <a href="https://www.ghanaweb.com/wall/private/login.php" class="logIn">Login</a>
                                    </div>
                 
                </form>
             </div>

           </div>
        </div>
        
        <div id="headerMid">
       <div id="headerAd">
           <div data-imk-uid='DESKTOP.SPORTS_(ARTICLE).LEADERBOARD.2' id='div-gpt-ad-1100003-0' style='height:90px; width:970px; text-align:center;'>
								<script>
									googletag.cmd.push(function() { googletag.display('div-gpt-ad-1100003-0'); });
								</script>
							</div></div>
        </div>
		
        <div id="topnav" class="topnav-en">You are here: <a href="https://www.ghanaweb.com">Home</a> &rarr; <a href="/GhanaHomePage/SportsArchive/">Sports</a> &rarr; <a href="browse.archive.php?date=20211008">2021 10 08</a> &rarr; <b>Article 1375603</b> </div>
        
        <div id="mainnav" >
          <ul id="mainnavinner" class="nav-en">
            <li class="navNews "><a href="https://www.ghanaweb.com/GhanaHomePage/NewsArchive/">
			News</a></li>
        	<li class="navSports current"><a href="https://www.ghanaweb.com/GhanaHomePage/SportsArchive/">
			Sports</a></li>
        	<li class="navBusiness "><a href="https://www.ghanaweb.com/GhanaHomePage/business/">
			Business</a></li>
        	<li class="navEntertainment "><a href="https://www.ghanaweb.com/GhanaHomePage/entertainment/"> Entertainment</a></li>
			<li class="navAfrica "><a href="https://www.ghanaweb.com/GhanaHomePage/africa/" rel="nofollow">
			Africa</a></li>
            <li class="navRadio "><a href="https://www.ghanaweb.com/GhanaHomePage/television/">TV / Radio</a></li>
            <li class="navWall "><a href="https://www.ghanaweb.com/wall/">Wall</a></li>
            	            <li class="navTonaton "><a href="https://ghanaweb.tonaton.com/en/ads?utm_source=ghanaweb&utm_medium=widget&utm_campaign=GhanaWeb_Widget&utm_term=navigation_desktop&utm_content=tonaton" rel="sponsored">Buy & Sell</a></li>
	                  </ul>

        </div>
      </header>


  <div id="mainbody" class="sports">     		     <div id="leftsection">
<div class="menuheading">Ghana Sports</div>
<ul>
	<li><a href="/GhanaHomePage/SportsArchive/">Home - Sports</a></li>
	<li><a href="/GhanaHomePage/soccer/">Soccer Portal</a></li>
	<li><a  href="browse.archive.php">Archived Sports News</a></li>
	<li><a  href="photo.archive.php">Sport Photos</a></li>
	<li><a href="/GhanaHomePage/television/?category=sports&sort=latest">Sport Videos</a></li>
	<li><a href="/GhanaHomePage/year-in-review/?review=sports">Year In Review (Sports)</a></li>
	<li><a rel="nofollow" href="/headlines/?cat=sports">Sports Headlines</a></li>

</ul>



<div class="menuheading">Soccer Resources</div>
<ul>
	<li><a href="/GhanaHomePage/league/">National Premier League</a></li>
   <!--< <li><a href="/GhanaHomePage/afcon2017/">AFCON 2017</a></li>
	li><a href="/GhanaHomePage/world_cup/">Brazil 2014</a></li> -->
	<li><a href="/GhanaHomePage/soccer/players.countries.php">Players Abroad</a></li>
	<li><a href="/GhanaHomePage/soccer/blackstars.php">National Team(s)</a> </li>
	<li><a href="/GhanaHomePage/soccer_transfers/">Transfers</a></li>
    <li><a href="/GhanaHomePage/afcon2019/">AFCON 2019</a></li>
</ul>


<div class="menuheading">Sports Websites</div>
<ul>
	<li><a rel="nofollow" href="/headlines/?site=9">Citi Sports</a></li>
  <li><a rel="nofollow" href="/headlines/?site=36">Ghana Soccernet</a></li>
  <li><a rel="nofollow" href="/headlines/?site=47">Ghana Sports Online</a></li>
</ul>


<div class="menuheading">Other Sports</div>
<ul>
	<li><a href="/GhanaHomePage/boxing/">Boxing</a></li>
	<li><a href="/GhanaHomePage/athletics/">Athletics</a></li>
	<li><a href="/GhanaHomePage/bball/">Basketball</a></li>
	<li><a href="/GhanaHomePage/bodybuilding/">Bodybuilding</a></li>
	<li><a href="/GhanaHomePage/cricket/">Cricket</a></li>
	<li><a href="/GhanaHomePage/golf/">Golf</a></li>
	<li><a href="/GhanaHomePage/hball/">Handball</a></li>
	<li><a href="/GhanaHomePage/hockey/">Hockey</a></li>
	<li><a href="/GhanaHomePage/martial_art/">Martial Arts</a></li>
	<li><a href="/GhanaHomePage/tennis/">Tennis</a></li>
	<li><a href="/GhanaHomePage/vball/">Volleyball</a></li>
	<li><a href="/GhanaHomePage/other_sports/">Other Sports</a></li>
</ul>


<div class="menuheading">GHANAsoccernet</div>
<a rel="sponsored noopener" target="_blank" href="https://ghanasoccernet.com/"><img style="margin:5px" src="https://cdn.ghanaweb.com/advert/ghanasoccernet5_160x100.jpg" alt="Click to go to GhanaSoccerNet"></a>

<div style="margin-bottom:5px;">
	</div>





<div class="menuheading" style="clear:both;">Other Sections</div>
				  	<ul>
						<li><a href="/">Homepage</a></li>
						<li><a href="/GhanaHomePage/NewsArchive/">News</a></li>
						<li><a href="/GhanaHomePage/business/">Business</a></li>
						<li><a href="/GhanaHomePage/SportsArchive/">Sports</a></li>
						<li><a href="/GhanaHomePage/entertainment/">Entertainment</a></li>
						<li><a href="/GhanaHomePage/africa/" rel="nofollow">Africa</a></li>
						<li><a href="/GhanaHomePage/television/">TV / Radio</a></li>
						<li><a href="/wall/">Wall</a></li>
					</ul></div>
<div id="medsection1" class="clearfix">
<!-- End of html generated by this->header() -->
<div class="article-left-col">
<a name="top"></a><p class="floatLeft">Sports News of Friday,  8 October 2021</p>
<div class="disclaimer" style="background: #ddf5ff; padding: 5px; margin: -4px 0px 0 22px; float: right; font-size: 14px; border-left: solid;"><a href="Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603?articleMode=readDisclaimer" rel="nofollow">Disclaimer</a></div><p class="floatRight"><strong>Source: </strong><a href="https://footballghana.com/" rel="nofollow noopener" target="_blank">footballghana.com</a></p>
<a id="date" style="display:none">2021-10-08</a><h1 style="clear: both;">Black Stars has a lot of quality players – Emmanuel Agyemang-Badu</h1>
<div class="option-bar">
<p><a rel="nofollow" href="artikel.php?ID=1375603&nav=previous">&laquo; Prev</a></p><p><a rel="nofollow" href="artikel.php?ID=1375603&nav=next">Next &raquo;</a></p><p class="last"><a href="artikel.php?ID=1375603&comment=0#com" rel="nofollow">Comments (0)</a></p>
<p class="listen"><a rel="nofollow" href="Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603?audio=1"><span class="icon"></span><span class="text">Listen to Article</span></a></p>

<ul id="share">
	<li><a rel="nofollow noopener" target="_blank" class="whatsapp" href="https://web.whatsapp.com/send?text=https%3A%2F%2Fwww.ghanaweb.com%2FGhanaHomePage%2FSportsArchive%2FBlack-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603">WhatsApp</a></li>
	<li><a rel="nofollow noopener" target="_blank" class="facebook" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.ghanaweb.com%2FGhanaHomePage%2FSportsArchive%2FBlack-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603">Facebook</a></li>
	<li><a rel="nofollow noopener" target="_blank" class="twitter" href="https://twitter.com/intent/tweet?text=https%3A%2F%2Fwww.ghanaweb.com%2FGhanaHomePage%2FSportsArchive%2FBlack-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603">Twitter</a></li>
	<li><a rel="nofollow" class="email" onClick="window.open('/GhanaHomePage/NewsArchive/emailnews.php?ID=1375603','Mailer','status=no,scrollbars=no,resizable=no,width=380,height=380');" href="/GhanaHomePage/NewsArchive/emailnews.php?ID=1375603" target="Mailer">Email This</a></li>	<li class="last"><a onClick="window.print();" href="#" class="print">Print This</a></li>
</ul></div>
<div class="article-left">
<p class="article-image"><a href="Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603?gallery=1"><img src="https://cdn.ghanaweb.com/imagelib/pics/819/81948914.295.jpg" alt="Former Black Stars midfielder, Emmanuel Agyemang-Badu" title="Former Black Stars midfielder, Emmanuel Agyemang-Badu" width="295" height="239"> </span></a><span class='image_caption'><span>Former Black Stars midfielder, Emmanuel Agyemang-Badu</span></span></p>
<div class="noPrint">
<div class="med_rec_lg_min">
<div data-imk-uid='DESKTOP.SPORTS_(ARTICLE).MEDIUM_RECTANGLE.4' id='div-gpt-ad-1300003-0'>
							<script>
								googletag.cmd.push(function() { googletag.display('div-gpt-ad-1300003-0'); });
							</script>
						</div></div></div>
</div>
<div style="-webkit-user-select: none; -webkit-touch-callout: none; -moz-user-select: none; -ms-user-select: none; user-select: none;"><p style='clear:right' id='article-123'>Former <a target='_blank' href='/GhanaHomePage/people/person.php?ID=3622'><a target='_blank' href='/GhanaHomePage/people/person.php?ID=3622'><a target='_blank' href='/GhanaHomePage/people/person.php?ID=3622'>Black Stars</a></a></a> midfielder, <a target='_blank' href='/GhanaHomePage/people/person.php?ID=5458'>Emmanuel Agyemang-Badu</a>, has rejected claims that Ghana lacks quality players.<br />
<br />
The four-time African champions have endured a difficult start to the 2022 World Cup qualifying campaign recording a win and a defeat after two matches.<br />
<br />
Ghana beats Ethiopia at home before losing to South Africa at the FnB stadium last month.<br />
<br />
A session of Ghanaians believes that the <a target='_blank' href='/GhanaHomePage/people/person.php?ID=3622'><a target='_blank' href='/GhanaHomePage/people/person.php?ID=3622'><a target='_blank' href='/GhanaHomePage/people/person.php?ID=3622'>Black Stars</a></a></a> lack quality players as compared to previous years and it is as a result the West African powerhouse is struggling in recent times.<br />
<br />
But according to Agyemang-Badu, Ghana has a lot of quality players considering the leagues some players play at the moment.<br />
<br />
“I don’t side with those claiming Ghana does not have quality players. We have the players but the key point is that there isn’t teamwork."<br />
<br />
"If you have players in the Serie A, Bundesliga, French Ligue 1, and Premier League and still claim the <a target='_blank' href='/GhanaHomePage/people/person.php?ID=3622'><a target='_blank' href='/GhanaHomePage/people/person.php?ID=3622'><a target='_blank' href='/GhanaHomePage/people/person.php?ID=3622'>Black Stars</a></a></a> lack quality, then, I don’t understand,” he said.<br />
<br />
<script data-cfasync="false" src="https://content.jwplatform.com/players/J8cxEnUO-eqk5XVg5.js"></script><br />
<br />
<iframe loading="lazy" width="715"  height="400"  src="https://www.youtube.com/embed/NpJ0druwAh0" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p></div>
<div class="related_articles" style="width: 100%;"><div style="clear: both; font-size: 90%; background-color: #eeeaea; padding: 5px; margin-top: 10px;">
<strong>Related Articles:</strong>
<ul
><li><a href="/GhanaHomePage/NewsArchive/Changed-Black-Stars-tipped-for-glory-against-Zimbabwe-1375441"  >‘Changed’ Black Stars tipped for glory against Zimbabwe</a></li>
<li><a href="/GhanaHomePage/NewsArchive/Qatar-2022-World-Cup-Qualifiers-Ghana-vs-Zimbabwe-preview-1375465"  >Qatar 2022 World Cup Qualifiers: Ghana vs Zimbabwe preview</a></li>
<li><a href="/GhanaHomePage/NewsArchive/Friday-Debate-Will-Milovan-s-Black-Stars-get-an-easy-win-against-Zimbabwe-1375474"  >Friday Debate: Will Milovan's Black Stars get an easy win against Zimbabwe?</a></li>
<li><a href="/GhanaHomePage/NewsArchive/Defender-Kassim-Nuhu-Adams-tips-Ghana-to-secure-2022-FIFA-World-Cup-berth-1375498"  >Defender Kassim Nuhu Adams tips Ghana to secure 2022 FIFA World Cup berth</a></li>
<li><a href="/GhanaHomePage/NewsArchive/Agyemang-Badu-confident-of-Black-Stars-win-against-Zimbabwe-in-World-Cup-qualifiers-1375546"  >Agyemang-Badu confident of Black Stars win against Zimbabwe in World Cup qualifiers</a></li>
<li><a href="dossier.php?ID=604"><strong>Read all related articles</strong></a></b></li>
</ul>
<br /><br />
<strong>Comments:</strong><br />
This article has no comments yet,<a href="artikel.php?ID=1375603&comment=0#com" rel="nofollow"> be the first to comment</a>
</div>
</div></div>
<!-- uploaded by: 103 updated by: -1 -->

<!-- Start of html generated by this->footer() -->
<div class='noPrint gw_ob_wrapper' style="clear:both; text-align:left;">
<a id="outbrain_lang" style="display:none">en</a><div lang="en" class="OUTBRAIN" data-src="www.ghanaweb.com/GhanaHomePage/SportsArchive/Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603" data-widget-id="AR_1" data-ob-template="Ghanaweb" ></div><script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script></div></div>
<div id="rightsection"><div class="med_rec_lg_min" style="margin:0 0 15px;"><div data-imk-uid='DESKTOP.SPORTS_(ARTICLE).WIDE_SKYSCRAPER.16' id='div-gpt-ad-1200003-1' style='height:auto; width:300px; text-align:center;'>
								<script>
									googletag.cmd.push(function() { googletag.display('div-gpt-ad-1200003-1'); });
								</script>
							</div></div>

<div id="tonaton_widget_main">
    <div class="head">
        <a rel="sponsored" href="https://ghanaweb.tonaton.com/en/ads?utm_source=ghanaweb&utm_medium=widget&utm_campaign=GhanaWeb_Widget&utm_term=widget_desktop_A&utm_content=tonaton" class="s">
            <h3 class="title">Buy & Sell</h3>
            <span><img src="https://cdn.ghanaweb.com/design/tonatonB/logo.png"></span>
        </a>
    </div>
    <div class="lead_category">
        <ul>
            <a rel="sponsored" href="https://ghanaweb.tonaton.com/en/ads/ghana/electronics?utm_source=ghanaweb&utm_medium=widget&utm_campaign=GhanaWeb_Widget&utm_term=widget_desktop_A&utm_content=electronics" class="">
                <li class="electronics">
                    <div class="image"><img src="https://cdn.ghanaweb.com/design/tonatonB/electronics.png"></div>
                    <span class="qty">(31,367)</span>
                </li>
            </a>
            <a rel="sponsored" href="https://ghanaweb.tonaton.com/en/ads/ghana/property?utm_source=ghanaweb&utm_medium=widget&utm_campaign=GhanaWeb_Widget&utm_term=widget_desktop_A&utm_content=property" class="">
                <li class="property">
                    <div class="image"><img src="https://cdn.ghanaweb.com/design/tonatonB/property.png"></div>
                    <span class="qty">(22,245)</span>
                </li>
            </a>
            <a rel="sponsored" href="https://ghanaweb.tonaton.com/en/ads/ghana/vehicles?utm_source=ghanaweb&utm_medium=widget&utm_campaign=GhanaWeb_Widget&utm_term=widget_desktop_A&utm_content=vehicles" class="">
                <li class="vehicles">
                    <div class="image"><img src="https://cdn.ghanaweb.com/design/tonatonB/vehicles.png"></div>
                    <span class="qty">(22,240)</span>
                </li>
            </a>
            <a rel="sponsored" href="https://ghanaweb.tonaton.com/en/ads/ghana/jobs-in-ghana?utm_source=ghanaweb&utm_medium=widget&utm_campaign=GhanaWeb_Widget&utm_term=widget_desktop_A&utm_content=jobs-in-ghana" class="">
                <li class="jobs">
                    <div class="image"><img src="https://cdn.ghanaweb.com/design/tonatonB/jobs.png"></div>
                    <span class="qty">(1,458)</span>
                </li>
            </a>
        </ul>
    </div>
    <div class="doorstep">
        <a rel="sponsored" href="https://ghanaweb.tonaton.com/en/ads?buy_now=1&utm_source=ghanaweb&utm_medium=widget&utm_campaign=GhanaWeb_Widget&utm_term=widget_desktop_A&utm_content=doorstepdelivery">
            <img src="https://cdn.ghanaweb.com/design/tonatonB/doorstep-delivery.png">
        </a>
    </div>
    <div class="post_btn">
        <a rel="sponsored" href="https://ghanaweb.tonaton.com/en/post-ad?utm_source=ghanaweb&utm_medium=widget&utm_campaign=GhanaWeb_Widget&utm_term=widget_desktop_A&utm_content=post-ad">
            <img src="https://cdn.ghanaweb.com/design/tonatonB/post_button.png">
        </a>
    </div>
</div>

<div class="med_rec_lg_min">
<div data-imk-uid='DESKTOP.SPORTS_(ARTICLE).MEDIUM_RECTANGLE.22' id='div-gpt-ad-1300003-1'>
							<script>
								googletag.cmd.push(function() { googletag.display('div-gpt-ad-1300003-1'); });
							</script>
						</div></div>
<div class="right-artl news">
		        <h3 class="title">News<span class="icon"><img src="https://cdn.ghanaweb.com/design/news.png"></span></h3>
		        <a href="/GhanaHomePage/NewsArchive/">
		            <div class="image"><div class='position'><span class='play-icon'></span></div><img src="https://cdn.ghanaweb.com/imagelib/pics/270/27093076.295.jpg" width="130" height="176" alt="The late Justice Samuel Kofi Marful-Sau" title="The late Justice Samuel Kofi Marful-Sau"></div>
		            <h3 class="text">A kiss, a fist and pointing  towards God – 3 symbolic things Marful-Sau did before his death</h3>
		        </a>
		    </div><div class="right-artl business">
		        <h3 class="title">Business<span class="icon"><img src="https://cdn.ghanaweb.com/design/business.png"></span></h3>
		        <a href="/GhanaHomePage/business/">
		            <div class="image"><img src="https://cdn.ghanaweb.com/imagelib/pics/587/58782278.295.jpg" width="130" height="70" alt="The world bank is projecting a strong growth in exports for the country next year" title="The world bank is projecting a strong growth in exports for the country next year"></div>
		            <h3 class="text">World Bank revises Ghana’s growth rate to 4.9% for 2021</h3>
		        </a>
		    </div><div class="right-artl entertainment">
		        <h3 class="title">Entertainment<span class="icon"><img src="https://cdn.ghanaweb.com/design/entertainment.png"></span></h3>
		        <a href="/GhanaHomePage/entertainment/">
		            <div class="image"><div class='position'><span class='play-icon'></span></div><img src="https://cdn.ghanaweb.com/imagelib/pics/159/15914114.295.jpg" width="130" height="73" alt="Deloris Frimpong Manso (Delay)" title="Deloris Frimpong Manso (Delay)"></div>
		            <h3 class="text">What at all do you sell at your restaurant? - Delay asks 24-year-old who owns mansion</h3>
		        </a>
		    </div><div class="right-artl africa">
		        <h3 class="title">Africa<span class="icon"><img src="https://cdn.ghanaweb.com/design/africa.png"></span></h3>
		        <a href="/GhanaHomePage/africa/" rel="nofollow">
		            <div class="image"><img src="https://cdn.ghanaweb.com/imagelib/pics/651/65194840.295.jpg" width="130" height="76" alt="Emmerson Mnangagwa, Zimbabwean President" title="Emmerson Mnangagwa, Zimbabwean President"></div>
		            <h3 class="text">Zimbabwean President Emmerson Mnangagwa caps 350 HIT graduates</h3>
		        </a>
		    </div><div class="right-artl opinions">
		        <h3 class="title">Opinions<span class="icon"><img src="https://cdn.ghanaweb.com/design/opinions.png"></span></h3>
		        <a href="/GhanaHomePage/opinions/">
		            <div class="image"><img src="https://cdn.ghanaweb.com/imagelib/pics/580/58059542.295.jpg" width="130" height="130" alt="Recent happenings on the LGBTQ+ topic in Ghana includes the Church criticizing the act" title="Recent happenings on the LGBTQ+ topic in Ghana includes the Church criticizing the act"></div>
		            <h3 class="text">Why is the Church of Pentecost silent on LGBTQ in America?</h3>
		        </a>
		    </div></div></div>
<div>           
        </div>
<div id="footer" style="margin-top:20px;">
  <ul id="footerinner">
    <li class="fstyle"><a href="/GhanaHomePage/aboutus.php">About Us</a></li>
    <li class="fstyle"><a href="/advertise/">Advertising</a></li>    <li class="fstyle"><a rel="nofollow" href="/GhanaHomePage/feedback.php?url=www.ghanaweb.com/GhanaHomePage/SportsArchive/Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603" onclick="NewWindow('/GhanaHomePage/feedback.php?url=www.ghanaweb.com/GhanaHomePage/SportsArchive/Black-Stars-has-a-lot-of-quality-players-Emmanuel-Agyemang-Badu-1375603', 'feedback', '550', '450','no') ;return false;">Feedback</a></li>
    <li class="fstyle"><a href="/GhanaHomePage/sitemap.php">Sitemap</a></li>
    <li class="fstyle"><a href="/GhanaHomePage/privacy_policy.php">Privacy Policy</a></li>
        
  </ul>
  
  <div id="footerrechts">
    Copyright &copy; 1994 - 2021 GhanaWeb. All rights reserved.  </div>
</div>


<script>var batch_slots=[]; googletag.cmd.push(function() {
	if(typeof($('#div-gpt-ad-1100003-0').attr('data-imk-uid')) != 'undefined'){ batch_slots = batch_slots.concat(gptadslots[1]); }
	if(typeof($('#div-gpt-ad-1300003-0').attr('data-imk-uid')) != 'undefined'){ batch_slots = batch_slots.concat(gptadslots[2]); }
	if(typeof($('#div-gpt-ad-1300003-1').attr('data-imk-uid')) != 'undefined'){ batch_slots = batch_slots.concat(gptadslots[3]); }
	if(typeof($('#div-gpt-ad-1200003-0').attr('data-imk-uid')) != 'undefined'){ batch_slots = batch_slots.concat(gptadslots[4]); }
	if(typeof($('#div-gpt-ad-1200003-1').attr('data-imk-uid')) != 'undefined'){ batch_slots = batch_slots.concat(gptadslots[5]); }
	googletag.pubads().refresh(batch_slots);
});
</script>

</div>

</div>
<script type="text/javascript">
	(function() {
		/** CONFIGURATION START **/
		var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});

		_sf_async_config.uid = 56378;
		_sf_async_config.domain = 'ghanaweb.com';
		_sf_async_config.flickerControl = false;
		_sf_async_config.useCanonical = true;
		_sf_async_config.useCanonicalDomain = true;
		_sf_async_config.sections = 'SportsArchive';
		_sf_async_config.authors = 'JE';
		/** CONFIGURATION END **/
		function loadChartbeat() {
			var e = document.createElement('script');
			var n = document.getElementsByTagName('script')[0];
			e.type = 'text/javascript';
			e.async = true;
			e.src = '//static.chartbeat.com/js/chartbeat.js';
			n.parentNode.insertBefore(e, n);
		}
		loadChartbeat();
		})();
		</script>


</div></div>


</body>
</html><!-- Generated in 0.039 seconds -->
